PermissionError: \site-packages\openturns\

Hello OpenTURNS community,

I tried to deploy a python application relying on OpenTURNS on a shared CITRIX server running on Windows 10.

I have admin rights and it works well for me.

For the targeted users, with or without admin rights on the machine, they get the following error message while executing “import openturns as ot”:

Traceback (most recent call last):
  File "<ipython-input-1-9b588cd27578>", line 1, in <module>
    import openturns as ot
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 724, in exec_module
  File "<frozen importlib._bootstrap_external>", line 859, in get_code
  File "<frozen importlib._bootstrap_external>", line 916, in get_data

PermissionError: [Errno 13] Permission denied: 'C:\\Anaconda3\\lib\\site-packages\\openturns\\'

Python 3.7.6, OpenTURNS 1.15
Installation from Anaconda 3, following the instruction from OpenTURNS installation page.

I guess it is more an Anaconda/Windows environment problem, but I post it there in case someone already faced something similar.

I’d give the same hint, maybe a missing conda activate or something related to conda as you said.
It can also happen that the pycache folders may be written with admin rights so regular users are not allowed to overwrite bytecode, but the error message does not seem to indicate that.
Else I have no clue.

Thank you for your feedback.
Nice to see that the OpenTURNS community is more active than ever.

After unsuccessfully trying several tricks and workarounds related to permissions, I finally gave up and solved the problem by manually installing Python and the needed modules manually, which works fine and is not much more complex to maintain.